prev
next
ru.linux.redhat
FromVladimir Donskoy2:5020/2992.0Date Write2018-03-09 22:18:09
ToAlexandr Kruglikov0:0/0.0Date Arrived2018-03-09 23:50:15
SubjRe^2: Сломался YUM
Attr
Hello Alexandr!

09 мар 18 23:14, Alexandr Kruglikov wrote to Vladimir Donskoy:

AV>>> Насколько я пони мяу, rpm --rebuilddb
VD>> Спасибо, помогло частично, хоть ругань исчезла:
VD>> Но проблема осталась...

AK> В первую очередь надо было yum-complete-transaction, ЕМНИМС.

Это я само собой выполнял, просто забыл написать очевидное...

AK> Потом package-cleanup --cleandupes

А вот это то самое, но не прошло:

>=================== Cut ===================

$ sudo yum-complete-transaction
Загружены модули: etckeeper, fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.hosteurope.de
* epel: mirror.freethought-internet.co.uk
* extras: ftp.hosteurope.de
* remi: remi.mirror.ate.info
* remi-php70: remi.mirror.ate.info
* remi-safe: remi.mirror.ate.info
* updates: ftp.hosteurope.de
No unfinished transactions left.
$ sudo package-cleanup --cleandupes
Загружены модули: etckeeper, fastestmirror
--> Проверка сценария
---> Пакет MariaDB-client.x86_64 0:5.5.58-1.el7.centos помечен для удаления
---> Пакет MariaDB-common.x86_64 0:5.5.58-1.el7.centos помечен для удаления
---> Пакет MariaDB-server.x86_64 0:5.5.58-1.el7.centos помечен для удаления
---> Пакет MariaDB-shared.x86_64 0:5.5.58-1.el7.centos помечен для удаления
---> Пакет at.x86_64 0:3.1.13-22.el7 помечен для удаления
---> Пакет bind-libs-lite.x86_64 32:9.9.4-51.el7 помечен для удаления
---> Пакет bind-license.noarch 32:9.9.4-51.el7 помечен для удаления
---> Пакет binutils.x86_64 0:2.25.1-32.base.el7_4.1 помечен для удаления
---> Пакет bx-nginx.x86_64 1:1.12.0-1.el7.centos.ngx помечен для удаления
---> Пакет cpp.x86_64 0:4.8.5-16.el7 помечен для удаления
---> Пакет cryptsetup-libs.x86_64 0:1.7.4-3.el7 помечен для удаления
---> Пакет dhclient.x86_64 12:4.2.5-58.el7.centos помечен для удаления
---> Пакет dhcp-common.x86_64 12:4.2.5-58.el7.centos помечен для удаления
---> Пакет dhcp-libs.x86_64 12:4.2.5-58.el7.centos помечен для удаления
---> Пакет dracut.x86_64 0:033-502.el7 помечен для удаления
---> Пакет gcc.x86_64 0:4.8.5-16.el7 помечен для удаления
---> Пакет glibc.x86_64 0:2.17-196.el7 помечен для удаления
---> Пакет glibc-common.x86_64 0:2.17-196.el7 помечен для удаления
--> Обработка зависимостей: glibc-common = 2.17-196.el7 пакета:
glibc-2.17-196.el7.i686
---> Пакет glibc-devel.x86_64 0:2.17-196.el7 помечен для удаления
---> Пакет glibc-headers.x86_64 0:2.17-196.el7 помечен для удаления
---> Пакет gtk-update-icon-cache.x86_64 0:3.22.10-4.el7 помечен для удаления
---> Пакет gtk3.x86_64 0:3.22.10-4.el7 помечен для удаления
---> Пакет initscripts.x86_64 0:9.49.39-1.el7 помечен для удаления
---> Пакет kmod.x86_64 0:20-15.el7_4.4 помечен для удаления
---> Пакет kmod-libs.x86_64 0:20-15.el7_4.4 помечен для удаления
---> Пакет kpartx.x86_64 0:0.4.9-111.el7 помечен для удаления
---> Пакет libblkid.x86_64 0:2.23.2-43.el7 помечен для удаления
---> Пакет libdb.x86_64 0:5.3.21-20.el7 помечен для удаления
---> Пакет libdb-utils.x86_64 0:5.3.21-20.el7 помечен для удаления
---> Пакет libgcc.x86_64 0:4.8.5-16.el7 помечен для удаления
---> Пакет libgomp.x86_64 0:4.8.5-16.el7 помечен для удаления
---> Пакет libgudev1.x86_64 0:219-42.el7_4.4 помечен для удаления
---> Пакет libmount.x86_64 0:2.23.2-43.el7 помечен для удаления
---> Пакет libpciaccess.x86_64 0:0.13.4-3.el7_3 помечен для удаления
---> Пакет libstdc++.x86_64 0:4.8.5-16.el7 помечен для удаления
---> Пакет libuuid.x86_64 0:2.23.2-43.el7 помечен для удаления
---> Пакет linux-firmware.noarch 0:20170606-56.gitc990aae.el7 помечен для
удаления
---> Пакет php.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-cli.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-fpm.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-gd.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-json.x86_64 0:7.0.26-1.el7.remi помечен для удаления
--> Обработка зависимостей: php-json(x86-64) = 7.0.26-1.el7.remi пакета:
php-common-7.0.26-1.el7.remi.x86_64
---> Пакет php-ldap.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-mbstring.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-mcrypt.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-mysqlnd.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-opcache.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-pdo.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-pear.noarch 1:1.10.5-2.el7.remi помечен для удаления
---> Пакет php-pecl-apcu.x86_64 0:5.1.8-1.el7.remi.7.0 помечен для удаления
---> Пакет php-pecl-xdebug.x86_64 0:2.5.5-1.el7.remi.7.0 помечен для удаления
---> Пакет php-process.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-pspell.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет php-xml.x86_64 0:7.0.26-1.el7.remi помечен для удаления
---> Пакет postgresql-libs.x86_64 0:9.2.23-1.el7_4 помечен для удаления
---> Пакет selinux-policy.noarch 0:3.13.1-166.el7_4.5 помечен для удаления
---> Пакет selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.5 помечен для
удаления
---> Пакет systemd.x86_64 0:219-42.el7_4.4 помечен для удаления
---> Пакет systemd-libs.x86_64 0:219-42.el7_4.4 помечен для удаления
---> Пакет systemd-sysv.x86_64 0:219-42.el7_4.4 помечен для удаления
---> Пакет transmission.x86_64 0:2.92-1.el7 помечен для удаления
---> Пакет transmission-cli.x86_64 0:2.92-1.el7 помечен для удаления
---> Пакет transmission-common.x86_64 0:2.92-1.el7 помечен для удаления
---> Пакет transmission-daemon.x86_64 0:2.92-1.el7 помечен для удаления
---> Пакет transmission-gtk.x86_64 0:2.92-1.el7 помечен для удаления
---> Пакет tzdata.noarch 0:2017c-1.el7 помечен для удаления
---> Пакет util-linux.x86_64 0:2.23.2-43.el7 помечен для удаления
---> Пакет yum.noarch 0:3.4.3-154.el7.centos помечен для удаления
--> Проверка сценария
---> Пакет glibc.i686 0:2.17-196.el7 помечен для удаления
--> Обработка зависимостей: libc.so.6 пакета:
bitrix-env-7.1-0.el7.centos.noarch
--> Обработка зависимостей: libc.so.6 пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.0) пакета:
bitrix-env-7.1-0.el7.centos.noarch
--> Обработка зависимостей: libc.so.6(GLIBC_2.0) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.1) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.1.3) пакета:
bitrix-env-7.1-0.el7.centos.noarch
--> Обработка зависимостей: libc.so.6(GLIBC_2.1.3) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.3) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.3.4) пакета:
bitrix-env-7.1-0.el7.centos.noarch
--> Обработка зависимостей: libc.so.6(GLIBC_2.3.4) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libc.so.6(GLIBC_2.4) пакета:
bitrix-env-7.1-0.el7.centos.noarch
--> Обработка зависимостей: libc.so.6(GLIBC_2.4) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libdl.so.2 пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libdl.so.2(GLIBC_2.0) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
--> Обработка зависимостей: libdl.so.2(GLIBC_2.1) пакета:
nss-softokn-freebl-3.28.3-8.el7_4.i686
---> Пакет php-common.x86_64 0:7.0.26-1.el7.remi помечен для удаления
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-rrd-2.0.1-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-memcache-3.0.9-0.9.20170802.e702b5f.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-xdebug-2.6.0-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-apcu-bc-1.0.3-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-apcu-5.1.9-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(api) = 20151012-64 пакета:
php-pecl-geoip-1.1.1-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(language) >= 5.3.3 пакета:
php-fedora-autoloader-1.0.0-1.el7.remi.noarch
--> Обработка зависимостей: php(language) > 5.4 пакета:
1:php-pear-1.10.5-6.el7.remi.noarch
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-rrd-2.0.1-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-memcache-3.0.9-0.9.20170802.e702b5f.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-xdebug-2.6.0-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-apcu-bc-1.0.3-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-apcu-5.1.9-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php(zend-abi) = 20151012-64 пакета:
php-pecl-geoip-1.1.1-1.el7.remi.7.0.x86_64
--> Обработка зависимостей: php-bz2 пакета: 1:php-pear-1.10.5-6.el7.remi.noarch
--> Обработка зависимостей: php-common >= 5.1.2 пакета:
php-zipstream-0.2.2-6.el7.noarch
--> Обработка зависимостей: php-ctype пакета:
php-fedora-autoloader-1.0.0-1.el7.remi.noarch
--> Обработка зависимостей: php-ftp пакета: 1:php-pear-1.10.5-6.el7.remi.noarch
--> Обработка зависимостей: php-pcre пакета:
1:php-pear-1.10.5-6.el7.remi.noarch
--> Обработка зависимостей: php-spl пакета:
php-fedora-autoloader-1.0.0-1.el7.remi.noarch
--> Обработка зависимостей: php-tokenizer пакета:
1:php-pear-1.10.5-6.el7.remi.noarch
--> Обработка зависимостей: php-zlib пакета:
1:php-pear-1.10.5-6.el7.remi.noarch
--> Проверка сценария
---> Пакет bitrix-env.noarch 0:7.1-0.el7.centos помечен для удаления
---> Пакет nss-softokn-freebl.i686 0:3.28.3-8.el7_4 помечен для удаления
---> Пакет php-fedora-autoloader.noarch 0:1.0.0-1.el7.remi помечен для удаления
---> Пакет php-pear.noarch 1:1.10.5-6.el7.remi помечен для удаления
---> Пакет php-pecl-apcu.x86_64 0:5.1.9-1.el7.remi.7.0 помечен для удаления
---> Пакет php-pecl-apcu-bc.x86_64 0:1.0.3-1.el7.remi.7.0 помечен для удаления
---> Пакет php-pecl-geoip.x86_64 0:1.1.1-1.el7.remi.7.0 помечен для удаления
---> Пакет php-pecl-memcache.x86_64 0:3.0.9-0.9.20170802.e702b5f.el7.remi.7.0
помечен для удаления
---> Пакет php-pecl-rrd.x86_64 0:2.0.1-1.el7.remi.7.0 помечен для удаления
---> Пакет php-pecl-xdebug.x86_64 0:2.6.0-1.el7.remi.7.0 помечен для удаления
---> Пакет php-zipstream.noarch 0:0.2.2-6.el7 помечен для удаления
--> Проверка зависимостей окончена

Зависимости определены


===============================================================================
Package Архитектура
Версия Репозиторий

Размер

===============================================================================
Удаление:
MariaDB-client x86_64 5.5.58-1.el7.centos @mariadb 43 M
MariaDB-common x86_64 5.5.58-1.el7.centos @mariadb 174 k
MariaDB-server x86_64 5.5.58-1.el7.centos @mariadb 174 M
MariaDB-shared x86_64 5.5.58-1.el7.centos @mariadb 5.1 M
at x86_64 3.1.13-22.el7 @base 95 k
bind-libs-lite x86_64 32:9.9.4-51.el7 @updates 1.7 M
bind-license noarch 32:9.9.4-51.el7 @updates 26 k
binutils x86_64 2.25.1-32.base.el7_4.1 @updates 22 M
bx-nginx x86_64 1:1.12.0-1.el7.centos.ngx @bitrix 4.0 M
cpp x86_64 4.8.5-16.el7 @base 15 M
cryptsetup-libs x86_64 1.7.4-3.el7 @base 947 k
dhclient x86_64 12:4.2.5-58.el7.centos @base 472 k
dhcp-common x86_64 12:4.2.5-58.el7.centos @base 240 k
dhcp-libs x86_64 12:4.2.5-58.el7.centos @base 146 k
dracut x86_64 033-502.el7 @base 874 k
gcc x86_64 4.8.5-16.el7 @base 37 M
glibc x86_64 2.17-196.el7 @base 13 M
glibc-common x86_64 2.17-196.el7 @base 115 M
glibc-devel x86_64 2.17-196.el7 @base 1.0 M
glibc-headers x86_64 2.17-196.el7 @base 2.2 M
gtk-update-icon-cache x86_64 3.22.10-4.el7 @base 58 k
gtk3 x86_64 3.22.10-4.el7 @base 17 M
initscripts x86_64 9.49.39-1.el7 @base 1.4 M
kmod x86_64 20-15.el7_4.4 @updates 240 k
kmod-libs x86_64 20-15.el7_4.4 @updates 90 k
kpartx x86_64 0.4.9-111.el7 @base 37 k
libblkid x86_64 2.23.2-43.el7 @base 256 k
libdb x86_64 5.3.21-20.el7 @base 1.8 M
libdb-utils x86_64 5.3.21-20.el7 @base 319 k
libgcc x86_64 4.8.5-16.el7 @base 175 k
libgomp x86_64 4.8.5-16.el7 @base 207 k
libgudev1 x86_64 219-42.el7_4.4 @updates 51 k
libmount x86_64 2.23.2-43.el7 @base 263 k
libpciaccess x86_64 0.13.4-3.el7_3 @updates 45 k
libstdc++ x86_64 4.8.5-16.el7 @base 1.0 M
libuuid x86_64 2.23.2-43.el7 @base 20 k
linux-firmware noarch 20170606-56.gitc990aae.el7 @base 126 M
php x86_64 7.0.26-1.el7.remi @remi-php70 8.2 M
php-cli x86_64 7.0.26-1.el7.remi @remi-php70 12 M
php-fpm x86_64 7.0.26-1.el7.remi @remi-php70 4.1 M
php-gd x86_64 7.0.26-1.el7.remi @remi-php70 204 k
php-json x86_64 7.0.26-1.el7.remi @remi-php70 80 k
php-ldap x86_64 7.0.26-1.el7.remi @remi-php70 121 k
php-mbstring x86_64 7.0.26-1.el7.remi @remi-php70 2.8 M
php-mcrypt x86_64 7.0.26-1.el7.remi @remi-php70 89 k
php-mysqlnd x86_64 7.0.26-1.el7.remi @remi-php70 888 k
php-opcache x86_64 7.0.26-1.el7.remi @remi-php70 405 k
php-pdo x86_64 7.0.26-1.el7.remi @remi-php70 381 k
php-pear noarch 1:1.10.5-2.el7.remi @remi 2.1 M
php-pecl-apcu x86_64 5.1.8-1.el7.remi.7.0 @remi-php70 233 k
php-pecl-xdebug x86_64 2.5.5-1.el7.remi.7.0 @remi-php70 751 k
php-process x86_64 7.0.26-1.el7.remi @remi-php70 187 k
php-pspell x86_64 7.0.26-1.el7.remi @remi-php70 47 k
php-xml x86_64 7.0.26-1.el7.remi @remi-php70 854 k
postgresql-libs x86_64 9.2.23-1.el7_4 @updates 671 k
selinux-policy noarch 3.13.1-166.el7_4.5 @updates 5.6 k
selinux-policy-targeted noarch 3.13.1-166.el7_4.5 @updates 18 M
systemd x86_64 219-42.el7_4.4 @updates 21 M
systemd-libs x86_64 219-42.el7_4.4 @updates 1.0 M
systemd-sysv x86_64 219-42.el7_4.4 @updates 3.9 k
transmission x86_64 2.92-1.el7 @epel 0.0
transmission-cli x86_64 2.92-1.el7 @epel 549 k
transmission-common x86_64 2.92-1.el7 @epel 3.0 M
transmission-daemon x86_64 2.92-1.el7 @epel 562 k
transmission-gtk x86_64 2.92-1.el7 @epel 3.1 M
tzdata noarch 2017c-1.el7 @updates 1.8 M
util-linux x86_64 2.23.2-43.el7 @base 8.1 M
yum noarch 3.4.3-154.el7.centos @base 5.5 M
Удаление зависимостей:
bitrix-env noarch 7.1-0.el7.centos @bitrix 20 M
glibc i686 2.17-196.el7 @base 14 M
nss-softokn-freebl i686 3.28.3-8.el7_4 @updates 450 k
php-common x86_64 7.0.26-1.el7.remi @remi-php70 7.9 M
php-fedora-autoloader noarch 1.0.0-1.el7.remi installed 15 k
php-pear noarch 1:1.10.5-6.el7.remi installed 2.1 M
php-pecl-apcu x86_64 5.1.9-1.el7.remi.7.0 installed 234 k
php-pecl-apcu-bc x86_64 1.0.3-1.el7.remi.7.0 @remi-php70 39 k
php-pecl-geoip x86_64 1.1.1-1.el7.remi.7.0 @remi-php70 68 k
php-pecl-memcache x86_64 3.0.9-0.9.20170802.e702b5f.el7.remi.7.0
@remi-php70 292 k
php-pecl-rrd x86_64 2.0.1-1.el7.remi.7.0 @remi-php70 85 k
php-pecl-xdebug x86_64 2.6.0-1.el7.remi.7.0 installed 809 k
php-zipstream noarch 0.2.2-6.el7 @epel 151 k

Итого за операцию

===============================================================================
Удалить 68 пакетов (+13 зависимых)

Объем изменений: 730 M
Продолжить? [y/N]: y
Downloading packages:
Running transaction check
ОШИБКА при проверке сценария на этапе зависимостей:
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-gd-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-process-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-xml-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-pspell-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-cli-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-ldap-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-mcrypt-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-fpm-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-opcache-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-json-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-mbstring-7.0.27-1.el7.remi.x86_64
php-common(x86-64) = 7.0.27-1.el7.remi нужен для
(установлен)php-pdo-7.0.27-1.el7.remi.x86_64
Выполнено!
(1, [])
$

>================= End cut =================

С уважением, Vladimir Donskoy.

--- GoldED+/W32-MSVC 1.1.5-b20170303
* Origin: DVB Station (2:5020/2992)